Jump to content
Taras Kushnir

Xpiks - open source software for microstocker

Recommended Posts

Guess it doesn't really matter now though if you are replacing exiftool soon...

 

Hi. I'm not that "replacing" exiftool. Rather changing the way I use it from programming point of view. I've just released another bugfix update - try to measure time importing your 40 files now :)

 

If would be nice if you can try your "clean test" and see if import fails on first batch again (because it doesn't for me)

Share this post


Link to post
Share on other sites

Oh, indeed. It's just a typo and it's fixed by now. BTW, don't you get updates via autoupdate? Like Xpiks doesn't pops up small update window to you with a link?

 

Yeah it does, I'm just in the habit of downloading it from the main page for some reason.

 

Anyway, the import time on my test files is now less than a second. Deleting the exiftool cache results in around a 6 second import time on first run but does not produce the previous errors and doesn't result in several processes remaining open and needing manual termination.

 

I only see two exiftool processes open now, rather than one per image, so I guess you've got one process importing them all sequentially which is why it is so much faster. To work that out I had to import 300 files at once to actually give me enough time to actually see the processes before they closed... still only took a few seconds.

 

Excellent improvement all in all.

Share this post


Link to post
Share on other sites

Found a few more minor bugs.

 

In the main Xpiks window shift-tab will tab backwards through the fields as intended except with the title field where it will just type tabs instead. Tabbing forward works fine though. If you click on the edit button with a single image selected shift-tab will reach the description field and then start typing tabs.

 

Where it gets interesting though is if you have more than one image selected. If you click edit with multiple images selected shift-tab will tab out of the description field and the cursor will disappear. Tabbing will not bring it back but if you hit tab ten or so times (tabbing through the toolbar buttons I guess) the cursor will start tabbing through the image fields behind the edit window and even allow you to type in those fields despite the editor still appearing to have focus.

 

I also noticed that returns can be typed in the description and title field. Not sure what happens if an image is uploaded with returns in the title but Windows treats them strangely in the file properties with returns appearing as spaces between words but then collapsing when you click the field to edit it so I imagine nothing good would come of it. Might be best to prevent return being entered or having it tab to the next field if you do hit it. Returns and tabs can also be entered if you edit in plain text mode even though it will just treat them as spaces when the keywords are submitted.

 

Whilst creating some currency illustration images I noticed that some symbols are accepted as keywords in Xpiks, other's are not. $, @, #, & and % are allowed to be entered as single keywords but pound, euro and yen symbols cannot be entered. Most stock sites don't let you search by individual punctuation marks or currency symbols anyway but on IS these symbols: $, £, €, ¥, !, ?, %, &, @, % are all used as keywords and do produce search results so I do use them on appropriate images. # doesn't seem to find anything there though.

 

Attempting to highlight and copy a word typed in as a keyword whilst it is still editable text will copy all the other keywords from that field instead of just the highlighted one. Conversely if two images have just one keyword which is the same in each and you try to copy and paste it to the other it will paste as editable text ready to edit. Nothing major but a little odd.

Share this post


Link to post
Share on other sites

I must be missing something. I have downloaded it, opened/extracted it and it still just sits there. How do I actually get it to run please? Win 7, 64.

Look in the file you extracted and click through the links until you find the one that opens the program (I don't remember what its named but it's the one with the Xpiks icon), then save the link somewhere like your desktop for easy access. At least that's how I got it going :)

Share this post


Link to post
Share on other sites

I must be missing something. I have downloaded it, opened/extracted it and it still just sits there. How do I actually get it to run please? Win 7, 64.

 

Please, extract it somewhere on your harddrive, go inside and double-click xpiks-qt.exe file, as @Linda Bestwick suggested.

Share this post


Link to post
Share on other sites

Hello Taras,

I dl your soft and installed it on my Surface 3. The size of the font is very very small on the screen. I found the way to increase the size of the keywords, but nothing else can be inceazed. Any idea?  And many thanks for your amaizing work! I guess that it will help me a lot!

Share this post


Link to post
Share on other sites

When I drag an drop the images on the application window and ask to import the metadata I get an error message and no metadata is imported.

(OsX 10.11.3)

Perhaps you forgot to install Exiftool as was written on the Downloads page at the main website. (You will need to install the Exiftool to use Xpiks. Download and install Exiftool from the official website)

 

If that wouldn't help, please check out how to report a bug http://ribtoks.github.io/xpiks/blog/2015/how-to-report-an-error. I'll assist you with your issue.

Share this post


Link to post
Share on other sites

Perhaps you forgot to install Exiftool as was written on the Downloads page at the main website. (You will need to install the Exiftool to use Xpiks. Download and install Exiftool from the official website)

 

If that wouldn't help, please check out how to report a bug http://ribtoks.github.io/xpiks/blog/2015/how-to-report-an-error. I'll assist you with your issue.

I had installed it already but does not work.

I send you the log file in PM

Share this post


Link to post
Share on other sites

Hello Taras,

I dl your soft and installed it on my Surface 3. The size of the font is very very small on the screen. I found the way to increase the size of the keywords, but nothing else can be inceazed. Any idea?  And many thanks for your amaizing work! I guess that it will help me a lot!

 

Hi

 

Can you please try this build? https://dl.dropboxusercontent.com/u/14391423/Xpiks-qt-v1.1.4.zip

 

If it will look better, I'll replace the public build for Windows with this.

Share this post


Link to post
Share on other sites

Hello Taras,

I dl your soft and installed it on my Surface 3. The size of the font is very very small on the screen. I found the way to increase the size of the keywords, but nothing else can be inceazed. Any idea?  And many thanks for your amaizing work! I guess that it will help me a lot!

 

Hi machiavel007 again. I acquired Surface 3 Pro and fixed DPI issue in Windows. Please, download Xpiks again from the link I've provided you (to dropbox) or from the main website.

 

Regards

Share this post


Link to post
Share on other sites

Hello Taras,

Many thanks for your message and action.

For me, same here: the letters of "Add files or Clear the filter", in green on a black background is very very small. The fonts are the same, as compare to the versions I had yesterday. Did I miss something ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...