Jump to content

Recommended Posts

Hello,

I tried it so many times and dont know what is the problem with my model release. I don´t get anyone of the Shutterstock stuff to answere me whats wrong. Can anyone here help me? 
I had the same model release for all of my models without any problems.

But this one always get a "Invalid Model Release: One or more of the attached model releases does not meet our requirements."

35784859.jpg

Link to post
Share on other sites

I can see you've had other model released images approved so I guess this rejection is not something obvious, like model not being an adult, dates not matching, using initials instead of full name, etc.

Normally I would say make sure the shoot date and metadata of the images match, but there is no shoot date. So can't be that.

Are you using a third party to upload the images such as Stocksubmitter? If so they (at least StSu) will default to the release you've uploaded before if the name is the same. So if there was a genuine problem with the first release, you could be submitting the same one over and over. If so rename the release so it is different from any uploaded before.

Did you email SS at the right place - submit@shutterstock.com or via the contact page from your dashboard? They should respond. If they did and just didn't give a helpful answer, persist. The first responders are usually contributors who will reply with cut and paste answers. If you persist they should eventually put you through to staff who will be able to look at the release.

 

Link to post
Share on other sites
  • 2 weeks later...
On 4/19/2021 at 5:29 PM, SariMe said:

Witness and contributor are different persons, right?

Hello and sorry for my late answer. I got no notification per email and does this settings now. Sorry! The witness and contributor both are me, also the same person. Must this be different persons?
 

On 4/19/2021 at 9:57 PM, Linda Bestwick said:

I can see you've had other model released images approved so I guess this rejection is not something obvious, like model not being an adult, dates not matching, using initials instead of full name, etc.

Normally I would say make sure the shoot date and metadata of the images match, but there is no shoot date. So can't be that.

Are you using a third party to upload the images such as Stocksubmitter? If so they (at least StSu) will default to the release you've uploaded before if the name is the same. So if there was a genuine problem with the first release, you could be submitting the same one over and over. If so rename the release so it is different from any uploaded before.

Did you email SS at the right place - submit@shutterstock.com or via the contact page from your dashboard? They should respond. If they did and just didn't give a helpful answer, persist. The first responders are usually contributors who will reply with cut and paste answers. If you persist they should eventually put you through to staff who will be able to look at the release.

 

Yes i use a thirdparty software named Xpiks to upload the pictures. I only changed small parts on my release, but always the same pictures/filenames.
I will try to rename the pictures before uplaoding.

I email SS 2 times via the contact page and told their the pictures name and the release model. The same I tried with submit@shutterstock.com This was maybe 2 weeks before. No answere (and not in my spam folder too...).

Link to post
Share on other sites
6 minutes ago, Heiner Weiss said:

Hello and sorry for my late answer. I got no notification per email and does this settings now. Sorry! The witness and contributor both are me, also the same person. Must this be different persons?
 

Yes i use a thirdparty software named Xpiks to upload the pictures. I only changed small parts on my release, but always the same pictures/filenames.
I will try to rename the pictures before uplaoding.

I email SS 2 times via the contact page and told their the pictures name and the release model. The same I tried with submit@shutterstock.com This was maybe 2 weeks before. No answere (and not in my spam folder too...).

The witness must be different from anyone else on the release. So using yourself twice, as contributor and witness, will get the rejection. No doubt about that.
Make sure when you redo the release with a new witness that all the dates match.

I haven't used xpiks for a very long time, so I don't know how their uploading of releases works, but I would suggest renaming the new release so it isn't the same as any you have used before. This way if Xpiks would normally default to a previously uploaded release (to avoid duplicating the same release) this wont happen and the new release will be used.

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...