Jump to content

katacarix

Members
  • Content Count

    12
  • Joined

  • Last visited

About katacarix

  • Rank
    Member

Recent Profile Visitors

182 profile views
  1. Reviewers reject my Editorial images with Press Credentials since a month with the same reason: Press Credential is missing. And since a month I do not get answer for my question from the Contributor Support. I sent several emails and still no answer.
  2. Hi, yes, I resubmitted them 3 times. It started in early May and I still have not got answer and the photos have been not reviewed properly.
  3. I am from Sydney, but visited Canberra several times. Love that city
  4. I submitted Editorial images with Press Credentials (case number was added to all images) but Reviewers rejected them with the reason: "Content was shot at an event that requires press credentials. Please send press credentials to credentials@shutterstock.com prior to submitting this content." That happened 4 times in a row in the last weeks and I still don't get answer from Shutterstock Representatives what is going on there. Additionally, 2 days ago I already posted this issue here on the forum but someone removed it.
  5. Same here. June was the worst month. Sales is now on average level but the review very slow ?
  6. Cannot see the submitted images in "Pending" phase.
  7. June was my worst month in 12 month time with 50% drop off. July is little bit better but still under the average sales
  8. Hi, since 30th April anytime when I submit Editorial images, bigstock rejects it with this message: "Reason: Editorial Designation -- This content can only be accepted for editorial use. Please select the "Editorial Usage" box on the "Info" tab before submitting." Of course, the images were submitted as Editorial and selected the "Editorial Usage". When I asked the support team, the answer is always the same: "1. submit smaller batches.2. don't use the multi-select to edit many images, try selecting editorial 1 image at at time, this may be a workaround. It is observed that metadata gets duplicated when multiselect is chosen.3. select the editorial category in addition to the checkbox.4. avoid apostrophes, brackets and so forth in the metadata." Okay, they don't read the emails just copy+paste the same text to everybody but I only submitted one image. I thought one image in a batch is quite small. Looks like not. I experience this issue since 30th April and after 3 weeks still nothing changed. Maybe bigstock does not accept editorial images anymore just forgot to inform the contributors. I checked the bigstock's blog, facebook and twitter but did not see any messages about this issue. Actually, they did not post anything since January. Do you know, what is going on there? Why bigstock does not accept editorial images? Why bigstock is not willing to fix the issue?
  9. Terrible and useless design without UX. It looks like who designed this Submission Page never worked as a Contributor. The old submission page was one of the best on the market. Now this one is full of pain, - I cannot oversee the keywords, have to scroll down, - when I tick more photos, lose all data which was added to the first image - colour contrast as well useless on the right side How can I change back to the old system?
  10. Hi, same issue, long waiting period for review but the worst thing is since the review is slower I don't have downloads. Before that generally had 20-30 downloads per week and now only 1 download in the last 4 days?! During the Christmas period had more downloads ...
×
×
  • Create New...